Нажмите "Enter", чтобы перейти к контенту

Как установить плагины в Vim с помощью Vundle

Для установки плагинов можно воспользоваться средством, под названием Vundle.

Для его установки воспользуйтесь следующей командой:

git clone https://github.com/VundleVim/Vundle.vim.git ~/.vim/bundle/Vundle.vim

Затем внесите нужные изменения в конфиг, прописав нужные плагины. Например, у меня это:

" let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'

" The following are examples of different formats supported.
" Keep Plugin commands between vundle#begin/end.
" plugin on GitHub repo
Plugin 'tpope/vim-fugitive'
" plugin from http://vim-scripts.org/vim/scripts.html
" Plugin 'L9'
" Git plugin not hosted on GitHub
Plugin 'git://git.wincent.com/command-t.git'
" git repos on your local machine (i.e. when working on your own plugin)
Plugin 'rstacruz/sparkup', {'rtp': 'vim/'}
" Install L9 and avoid a Naming conflict if you've already installed a
" different version somewhere else.
" Plugin 'ascenator/L9', {'name': 'newL9'}

Plugin 'preservim/nerdtree'
Plugin 'flazz/vim-colorschemes'
Plugin 'tpope/vim-surround'
Plugin 'xolox/vim-misc'
Plugin 'xolox/vim-colorscheme-switcher'

" All of your Plugins must be added before the following line

Затем запустите Vim и выполните команду :PluginInstall. Vundle установит нужные плагины, и при следующем запуске уже можно будет ими пользоваться.

Подписаться
Уведомить о
guest

Капча загружается...

0 комментариев
Межтекстовые Отзывы
Посмотреть все комментарии